AZ-104 Exam Details

  • Exam Code
    :AZ-104
  • Exam Name
    :Microsoft Azure Administrator
  • Certification
    :Microsoft Certifications
  • Vendor
    :Microsoft
  • Total Questions
    :852 Q&As
  • Last Updated
    :May 28, 2026

Microsoft AZ-104 Online Questions & Answers

  • Question 191:

    HOTSPOT

    You have an Azure subscription named Subscription1 that contains a resource group named RG1.

    In RG1, you create an internal load balancer named LB1 and a public load balancer named LB2.

    You need to ensure that an administrator named Admin1 can manage LB1 and LB2. The solution must follow the principle of least privilege.

    Which role should you assign to Admin1 for each task? To answer, select the appropriate options in the answer area.

    NOTE: Each correct selection is worth one point.

  • Question 192:

    You have a Microsoft Entra tenant named contoso.com.

    You collaborate with an external partner named fabrikam.com.

    You plan to invite users in fabrikam.com to the contoso.com tenant.

    You need to ensure that invitations can be sent only to fabrikam.com users.

    What should you do in the Microsoft Entra admin center?

    A. From Cross-tenant access settings, configure the Tenant restrictions settings.
    B. From Cross-tenant access settings, configure the Microsoft cloud settings.
    C. From External collaboration settings, configure the Guest user access restrictions settings.
    D. From External collaboration settings, configure the Collaboration restrictions settings.

  • Question 193:

    You have an Azure subscription named Subscription1. Subscription1 contains a virtual machine named VM1.

    You have a computer named Computer1 that runs Windows 10. Computer1 is connected to the Internet.

    You add a network interface named VM1173 to VM1 as shown in the exhibit. (Click the Exhibit tab.)

    From Computer1, you attempt to connect to VM1 by using Remote Desktop, but the connection fails.

    You need to establish a Remote Desktop connection to VM1.

    What should you do first?

    A. Change the priority of the RDP rule.
    B. Delete the DenyAlllnBound rule.
    C. Start VM1.
    D. Attach a network interface.

  • Question 194:

    HOTSPOT

    You have an Azure subscription that contains the vaults shown in the following table.

    You create a storage account that contains the resources shown in the following table.

    To which vault can you back up cont1 and share1? To answer, select the appropriate options in the answer area.

    NOTE: Each correct answer is worth one point.

  • Question 195:

    You have an Azure Log Analytics workspace named Workspace1 that collects Windows security logs into the SecurityEvent table.

    You need to find failed sign-in attempts in the last 60 minutes.

    Which query should you run in Workspace1?

    A. SecurityEvent | where EventID == 4625 | where TimeGenerated >= ago(60m)
    B. SecurityEvent | where EventID == 4624 | where TimeGenerated >= ago(60m)
    C. search in (SecurityEvent) "4625" | where TimeGenerated >= ago(60m)
    D. SecurityEvent | where TimeGenerated >= ago(60m) | summarize count() by Account

  • Question 196:

    Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.

    After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.

    You have an Azure container registry named Registry1 that contains an image named image1.

    You receive an error message when you attempt to deploy a container instance by using image1.

    You need to be able to deploy a container instance by using image1.

    Solution: You create a private endpoint connection for Registry1.

    Does this meet the goal?

    A. Yes
    B. No

  • Question 197:

    HOTSPOT

    You plan to deploy 20 Azure virtual machines by using an Azure Resource Manager template. The virtual machines will run the latest version of Windows Server 2016 Datacenter by using an Azure Marketplace image.

    You need to complete the storageProfile section of the template. How should you complete the storageProfile section? To answer, select the appropriate options in the answer area.

    NOTE: Each correct selection is worth one point.

  • Question 198:

    You have an Azure subscription that contains a storage account named storage1. The storage1 account contains a container named container1.

    You need to configure access to container1. The solution must meet the following requirements:

    1. Only allow read access.

    2. Allow both HTTP and HTTPS protocols.

    3. Apply access permissions to all the content in the container.

    What should you use?

    A. an access policy
    B. a shared access signature (SAS)
    C. Azure Content Delivery Network (CDN)
    D. access keys

  • Question 199:

    You have an Azure subscription that contains an Azure virtual machine named VM1. VM1 runs a financial reporting app named App1 that does not support multiple active instances.

    At the end of each month, CPU usage for VM1 peaks when App1 runs.

    You need to create a scheduled runbook to increase the processor performance of VM1 at the end of each month.

    What task should you include in the runbook?

    A. Add the Azure Performance Diagnostics agent to VM1.
    B. Modify the VM size property of VM1.
    C. Add VM1 to a scale set.
    D. Increase the vCPU quota for the subscription.
    E. Add a Desired State Configuration (DSC) extension to VM1.

  • Question 200:

    DRAG DROP

    You are developing an Azure web app named WebApp1. WebApp1 uses an Azure App Service plan named Plan1 that uses the B1 pricing tier.

    You need to configure WebApp1 to add additional instances of the app when CPU usage exceeds 70 percent for 10 minutes.

    Which three actions should you perform in sequence? To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the correct order.

    Select and Place:

Tips on How to Prepare for the Exams

Nowadays, the certification exams become more and more important and required by more and more enterprises when applying for a job. But how to prepare for the exam effectively? How to prepare for the exam in a short time with less efforts? How to get a ideal result and how to find the most reliable resources? Here on Vcedump.com, you will find all the answers. Vcedump.com provide not only Microsoft exam questions, answers and explanations but also complete assistance on your exam preparation and certification application. If you are confused on your AZ-104 exam preparations and Microsoft certification application, do not hesitate to visit our Vcedump.com to find your solutions here.